Omnivore is seeing a high failure rate from the Cloudconnect APIs
Incident Report for Omnivore.io
Resolved
API errors from NCR Cloud Connect have subsided. We will continue to monitor the situation.
Posted May 21, 2020 - 09:05 PDT
Update
Omnivore continues to encounter degraded performance when contacting Cloud Connect APIs. Although successful API calls to the Cloud Connect API have improved slightly, we currently see approximately 30% of calls failing. We are in contact with NCR and are working to remediate the errors as quickly as possible.
Posted May 21, 2020 - 06:57 PDT
Update
This will be the last regular status update on this incident for today, Wednesday, May 20.

Starting at approximately 9:30UTC Omnivore began seeing an increased error rate when contacting NCR's Cloud Connect API. The error rate of Omnivore's API calls to Cloud Connect API went from less than 1% to approximately 50%, primarily due to timeouts awaiting a response from the Cloud Connect API. Omnivore has engaged NCR API support in resolving the issue and continues to actively monitor the situation.

This issue will be left open until error rates for Cloud Connect stores have returned to an acceptable level, however no further updates will be made today until new information becomes available, or error rates return to normal.
Posted May 20, 2020 - 14:41 PDT
Update
We are still seeing elevated errors with Cloudconnect and our engineers are monitoring the situation.
Posted May 20, 2020 - 10:14 PDT
Update
We are continuing to work on a fix for this issue.
Posted May 20, 2020 - 08:32 PDT
Identified
no update, but we're still investigating,
Posted May 20, 2020 - 08:32 PDT
Investigating
We are currently investigating this issue.
Posted May 20, 2020 - 06:17 PDT
This incident affected: Cloud Integrations (Aloha Cloud Connect).