We released a fix around 17:08 UTC and verified that Location Status reporting has returned to normal behavior.
Posted Feb 24, 2026 - 09:17 PST
Update
At this time, we believe the impact for the duration of this incident was limited to incorrectly reporting the Location Status. We no longer believe that API calls experienced increased latency or error rates.
Posted Feb 24, 2026 - 08:37 PST
Identified
We have identified a possible cause of the increased latency and are working on a fix.
Posted Feb 24, 2026 - 08:16 PST
Investigating
Around 9:02 UTC, we noticed a steady increase in the number of Locations entering a "degraded" state. This seems related to a small increase in average Agent Heartbeat response times to slightly above 2 seconds. This is causing some Locations to flap between "online" and "degraded". Customers may see a minor increase in API response times as a result. We are actively investigating the cause at this time.